3
Vote

Installation error

description

Error occurred during installation process. Error message: "This setup requires Internet Information Server 4.0 or higher and Windows NT 4.0, ..."
I'm using Windows XP SP 2 with IIS 5.1

comments

LoicBaumann wrote May 16, 2007 at 1:50 PM

Initially the WebService requires to be installed on the same computer than the TFS Server, in order to use the same AppPool than TFS to inherit the required access rights to TFS. So you have to install the whole thing on a Windows 2003 Server with IIS 6.0.For production purpose, I strongly recommend you to do that way.

Now for development/debugging purpose you can install the Web Service on a Windows XP/IIS 4.0 (that's what I did to develop it), but I'm afraid the installer won't let you to do so. From now, you'll have to run the setup on a Win2K3, then copy the files back in your Windows XP.

wrote May 25, 2007 at 8:02 AM

wrote May 14, 2008 at 1:22 AM

Abhay wrote Oct 6, 2008 at 6:14 AM

I have installed it my server. it was successfully installed but how do i copy back up file from server to my client machine. client config is XP2002 sp3 IIS5.1. I am using TFS2005 and tring to install wicreater1.4.

Abhay wrote Oct 6, 2008 at 6:16 AM

2nd thing:- On server when i try to run wicreator Admin it throws an error object refrence not set to instance of the object. pls help

LoicBaumann wrote Oct 6, 2008 at 5:10 PM

You followed the instructions in the word document ?
I don't understand the "...but ho do i copy back up file from server to my client machine", please explain more precisely.

Regards,
Loic

Abhay wrote Oct 7, 2008 at 6:32 AM

Hi Loic, I have the following queries regarding this tool:
  1. Can we use WICreator 2.0 with TFS 2005, as I am using TFS 2005 and I was able to successfully install the WICreator 2.0 on my server but when I am trying to run the WI administration, as mentioned in the document its giving the error "Object reference not set to an instance of the object."
  2. Setup for WI Creator 1.4 is not available on this site, so I am not able to try it and also If I install the version 1.0, the administration option is not available and I have to run the creator from the "$...\TFS 2005\web services\WINetwork\CegWICreator_1_0_0_17.application" which too is giving some error.
I am using TFS 2005 on the windows server 2003 SP2 machine and my client machine configuration is windows xp professional 2002 SP3. I am not able to use any version of this tool neither on the server nor on the client machine. please suggest.

LoicBaumann wrote Oct 7, 2008 at 6:16 PM

I'm afraid that with TFS 2005 you'll have to stick with the 1.4 beta (there's the release files including the setup on the beta).
The reason of this is because the 2.0 application uses a feature of Team System that were bugged in the 2005 version, so you wouldn't want to try it.

If the features you're looking for are handling hierarchy with Work Items and using global workflow between them, the 1.4beta will do fine. But unfortunately you can't use the merge by Work Item feature with TFS 2005.

If upgrading to 2008 is a possibility, I strongly encourage you to do so (not even if you're not using WICreator ;) ).

Regards,
Loïc

wrote Feb 13, 2013 at 5:45 PM